Show Categories
kebounek posted Jul 11 '20 at 9:47 pm

The quest giver is supposted to give me rider which has the abilitry to kill minions and fly around the area ...

well nothing happens when i talk to him and kill 80 minions manually is kinda pain

Ark posted Jul 11 '20 at 1:44 am

This chain plays flawless, except for the last bit. In the last quest, i cant make the bundle of relics work anywhere in the town square. I assume this event must be pretty hard to emulate, as the only time I ever saw it working in privates was in this video: (No need to skip tru, the link starts at the said part)

Ark posted Jul 10 '20 at 7:41 pm
  1. The questline to get the scholomance key is flawless, even the infamous "mark the towers" quest works. Kudos to staff.

  2. Scholomance´s first inner gate will not open after slaying the guards and skeletons around it. A geared 80 can just jump down from the sides, but that also means they are not gong to walking OUT to deliver the nearby quests and retain the instance. A lower leveled team touring the place will have to go back from the doorstep without seeing further than the first four mobs.

  3. The gate to the chamber of summoning also didnt open. I suspect every gate that relies on a script to open on its own will also not open. Lack of access to the chamber of summoning prevents the completion of the quests for the deeds of the Barov family (Alliance and horde versions) as well as the quest "Kirtonos the Herald".

  4. The torch-disguised lever in Janice´s area works and opens the related gate, but the treasure chest behind it can not be clicked.

  5. Alexei Barov has a weird pathing bug, as if there was a hole above him pulling him upwards to the level above. I had to fight him over there.

  6. Darkmaster Gandling, although well scripted in his arcane mage spells, will not use his gimmick spell to teleport a player into one of the adjacent rooms, locking its gate and sumoning undead minions inside. If memory serves, the gate would only unlock after the minions are defeated.

Ark posted Jul 9 '20 at 2:45 am

This rare from howling fjord , KING PING, is hitting too hard for its level. It is a green kill for my character at its level of 71, even with it being elite, its taking me down in like 2-3 hits. I did some wow research and found no mention to its high damage, just one commenter saying he casually killed king ping at-level (71). My character was level 76 with tank demon, and i tried an extra time to confirm.
EDIT: managed it with a lvl 80 3.6k hunter, but it did kill my lvl 80 pet before going down and left quite a notch on me. lvl 80 versus 71, gray fight. I think King Ping damage is off. Also hes right on the way of the kamagua quest line.

Ark posted Jul 8 '20 at 7:03 pm

When i released earlier in a fos group ( i entered the wrong instance as they were already in , and died) , my character "died again" when spawning at the icc spirit healer location (No spirit healer there byt the way, i wonder if that is intentional or a bug, a spirit healer there would have solved the isue i think). Both my character and the gryphon were "dead" on the ground, while in spirit form. I had to leave game and clear cache to return to proper spirit form and to get a new ghost gryphon, but i could not revive from either the location where i died (POS) nor the location where the party was (FOS). Unstucking tru the game tool did not work in spirit form. As of the writting of this, im still unable to bring Ark back to life.


EDIT: unstuck seems to have worked only when i left game again, cleaned cache again and returned. Had to find the SH at goldshire but all is good now. But seriously, how about a spirit healer there where we spirit-spawn after we release in the ICC zone? I think it would deal with such issues in the footure. Also the word F - U - T is banned preventing me from spelling FOOTOORE properly and thats a bit weird.

Ark posted Jul 8 '20 at 4:36 pm

I decided to wait 2 days so i could make sure before posting. On the day i congratulated administration for the last patch, i did so mainly because i noticed WG dailies were back on the map, and once i tested them, there were no isues at all - Meaning, no crashes after two characters of mine did all dailies, horde and ally side. That made me really happy. However, the quests seem to have turned into normal quests and will not become repeatable anymore. I am not sure if that is intentional or not. Could these quests be fixed, and if its not a bug, then could I suggest that these quests become dailies again ? My reasoning is - 1. These quests are dailies in other servers 2 - These quests are currently the only way i can gather honor to collect certain items ( items I always disagreed about them being available for PVE emblems since retail ) and 3 - When you want to explore elite content in the Old World, it is a very good idea to get PVE-crit immune, and in WOTLK, when not playing a tank character, I always did that tru Res rather than tru Def. Sorry for the long rant.

Ark posted Jun 20 '20 at 5:26 am

When starting a mage today, i couldnt help but notice that when casting the polimorph spell (turning mobs into sheep), the sheep was able to use all of its abilities and spells if in range. This led to the funny episode of a defias rogue wizard (goldshire) casting ice bolts on me while in sheep form.

recent by Ark  ·  Jul 8 '20 at 1:40 pm
Ark posted Jun 25 '20 at 6:18 pm

When a mage uses the glyph of eternal winter to make their water elemental into a permanent pet, the new permanent pet will not behave as the other permanent pets, and will not despawn/respawn when you warp, teleport, portal, hearthstone, or even mount. This leads to wow classic behavior where your mount follows you normally as you ride. This is expected of enslaved demons, but not of glyphed water elementals, as i have experience with them in other servers. This causes an issue where the water elemental may bug due to distance, becoming impossible to bring to you, impossible to dismiss / ressumon, and impossible to control. Every time this happens, i am forced to quit the game and clean my cache to make the elemental disappear. This also led me to the inconvenience of having to remember dismissing the elemental every time i am to warp hearth or even mount.

recent by Ark  ·  Jul 8 '20 at 1:38 pm
Ark posted Jul 8 '20 at 2:06 am

During the remarkable dialogue between High Overlord Saurfang and Garrosh Hellscream in Warsong Hold (Borean Tundra, Northrend) , Saurfang suddenly shoots a very anticlimatic line, something more appropriate for an automaton and completely out of context. Maybe its a text mismatch from some gnomish robot quest, or maybe an Ulduar machine or something like that ?Picture:

Ark posted Jul 7 '20 at 5:43 pm

The quest "Aces High!" By Corastrazza (Coldarra), in its initial state ( the yellow quest that will lead to the daily) can not be completed by any normal means. Unlike the fully working dragons inside the occulus, the dragon provided by Corastrazza has only one working command, being the last one (Fly?). Once pushed that command remains "pressed in" . As no attacks will light up regardless of range, i can not slay the blue drakes. I could think of something like going up there kiting them to a nearby platform and elite-ing my way to victory but thats not the way this low-level daily was meant to be played.

Evangelion4k posted Jul 5 '20 at 5:18 am

Hola soy nuevo y no puedo jugar y veo la guía completa para instalar. Estoy en el juego y solo veo el parche de descarga del 0% y necesito reiniciar el juego. única vez.
Por favor, dame un enlace para descargar el juego o parche para jugar aquí, o adiós

recent by Clone  ·  Jul 6 '20 at 4:04 pm
Melv posted Jul 6 '20 at 9:19 am
  1. It goes to 11 doesn’t give you control of a harpoon, it just gives a simple buff, but no ‘vehicle’
  2. Let’s go surfing now clicking the leaver activates the harpoon, but it won’t fly down to valgarde (just stays there under you and cannot dismount) and if you hit the Escape button, it gives an WoW error.
  7. For the quests from 3-7, you cannon get into the iron rune construct suit. The table shows the dialogue, but upon clicking the dialogue, nothing happens.
  8. Sorlof’s Booty Upon riding the ship, there should be a cannon in front of the ship (
  9. Seeds of the blacksouled keepers Right-clicking the spores with the quest item, says invalid target.
  10. Battle at valhalas – the return of sigrid iceborn The npc spawns, but is not attackable.
  11. The flesh giant champion Margrave Dhakar is not spawned, neither is Morbidus.
  12. The black knight’s fall Speaking to squire Cavin does not give you the option to battle the dark knight.
  13. The drakkensryd Cannot target the adds, and if you manage to kill 1 thorugh aoe, it doesn’t count towards the quest.
  14. Fury of the frostborn king Even though the quest appears completed upon getting the q item from the chest, when reaching creteus, he doesn’t have the yellow question mark above his head.
  15. No event starting, thorim doesn’t show up (npc ID – 30390) there are 2 different thorim’s (ID’s).
Ark posted Jul 5 '20 at 9:54 am

In this quest we approach a campfire and plant a banner and we are supposed to defend it from some enemies. Well, i say this banner can defend itself pretty well without my help, as its not being attacked (So i cant complete the second requisite of the quest) , it follows me as a guardian and it even gets in pose to fight my enemies. Thats a black belt banner im telling you !

Ark posted Jul 5 '20 at 9:51 am

I searched and searched until my underwater breath spell ran out, and i can not find the reagent pouch inside either section of the underwater ship.

Ark posted Jul 5 '20 at 9:49 am

During this quest, we fight at the underground ring in uthgarde catacombs, and we are supposed to defeat mobs in there to make a sub boss appear, to get a cipher from him. I cant seem to make the sub boss appear, the mobs are all watching around and outside of the circle, and the circle is full of prisioners and valkyr spirits that i think are probably misplaced from one floor above.

Ark posted Jul 5 '20 at 9:18 am

At caudros isle (eastern howling fjord, near the starting point) , at the house where the NPC and questgiver "Lt. Icehammer" is ( Just east of uthgarde keep) , there are 4 Winterskorn enemies at the entrance, and 2 of them refused to stay dead. While me and my minion fought them, those two displayed as "DEAD" and had empty life gauges, yet they kept coming at us. Two other mobs nearby were alive and fine. The npc and his companions inside the cabin ignored the mobs. Eventually, my Felguard managed to kill them all, so i think its only a graphical bug, BUT, once the bugged units were really "dead", i could not loot them - right clicking them would still bring the melee combat interface / stance, so i guess they werent that "dead". Im scared of delivering the quests to icehammer now. Please exorcize them.


Ark posted Jul 2 '20 at 3:03 am

Ok this will be a bit tough to explain but i will try.

When i use the hunter skill "Deterrence" ((I usually do it to get 5 seconds to lay two traps, or else to force a late counterattack) ), i am getting a strange bug afterwards. I dont know yet if the bug is only visual, but according to the combat log, I am unable to perform auto attacks after the detterrence timer ends.

The hunter remains on combat poise and any special abilities I use will work, but no auto attack.

If in such state, i use a raptor strike, the raptor strike button remains lit, waiting for a sequence, undefinitely, untill combat is over. In that time i may use as many mongoose bites or wing clips or whatever else, and i dont know if they are getting the raptor strike boost or not.

Even as combat ends, the hunter remains on combat poise.

The bug persists untill i quit the client and clean my cache.

The bug is back if I use deterrence again, regardless of cleaning my cache or not.

I am fully aware that 99.999% hunters are not affected by this, because deterrence and auto attack are not mainstream, but still, here it is.

recent by Tango  ·  Jul 3 '20 at 2:27 am
Melv posted Jun 24 '20 at 7:14 am
  1. The Air Stands Still

    the kills don’t count towards completing the quest.

  2. You’ll need a bear
    NPC phasing out when trying to reach him.

  3. The Grand Melee – low priority
    Can’t duel them. Even though you can talk to them, they won’t start the duel.

  4. Basic Chemistry
    The screen shows: batch plague neutralized, but the quest doesn’t complete

  5. Steamtank Surprise
    The vehicles cannot be mounted.

  6. Springing the Trap
    Trying to light the brazier, but nothing happens

  7. Fuel for the Fire
    You can take control of an abomination, but the moment in enters the range of a enemy, it auto-dismisses

  8. By Fire Be Purged
    using the torch does not brun the corpses

  9. Banshee’s Revenge
    Blowing the horn does not summon Overthane Balargarde

  10. Seeds of Chaos
    Cannot mount the gryphon and killing units while not on the gryphon does not count towards completion.

  1. That’s Abominable

  2. Killohertz
    The NPC on the alliance platform is missing.

  3. Fervor of the Frostborn
    The iron watcher is missing.

  4. Krolmir, Hammer of Storms
    Thorim doesnt appear to talk. The dialogue between king jokkum and thorim doesn’t happen. The quest appears complete, but you can’t give it to anyone.

  5. The Forgotten Tale
    Talking to the spirits doesn’t complete.


1.THe Echo of Ymiron
When you enter the house as a spirit, there should be a “family of vrykul”.

2.Drop it then rock it
Placing the banner should start an event where vrykul would come and attack. You plant the banner, but then nothing happens.

3.Mounting UP – low priority

4.Reclusive runemaster
Even though he yells the name, the quest won’t appear complete

5.Mystery of the Infinite, Redux
Planting the hourglass doesn’t start the event. No adds appear.

6.The plume of Alystros
Using the plume doesn’t make alystros attackable.

recent by Tango  ·  Jun 30 '20 at 1:36 pm
Ark posted Jun 29 '20 at 8:41 am

I just noticed that i am only able to obtain super healing potions (the outland healing potion) and super mana potions from rogue lockboxes while in outlands. When i play other characters who level or even twink in outlands, all i get seems to be major healing potions, the top potion tier of vanilla. I remember from other servers, having looted super healing potions in outlands normally. Citing Source:

recent by Ark  ·  Jun 30 '20 at 6:07 am
Ark posted Jun 30 '20 at 5:33 am

During the daily quest "keeping the enemy at bay" and its mother quest "intercepting the reinforcements" (Isle of Quel Danas) the flame bomb will not ignite the sails so it will not register completion. The other bombing runs in the island and in outlands work fine.

Tango posted Jun 29 '20 at 11:10 pm

Hello Stormers,

Lately we received questions regarding what graphical settings are best in order to get the most out of this 12 year old game.

So we decided to give you this quick guide of the settings we're using.

  1. Thanks to you can download this texture mod, that will give you HD Legion Tilesets. To apply it just unzip the archive and copy the "Patch-T.MPQ" file inside the WoW "Data" folder. After this, you'll have to delete the game Cache, then you can login.

  2. Once you're in-game you'll have to open the Video settings menu and use the following settings:5efa4a5c195eb

That's all folks!

Ark posted Jun 29 '20 at 9:03 am

The quest "return to the abyssal shelf" (Horde, Hellfire peninsula) is set to infinite repetitions per day with no rewards, despite being marked with a yellow exclamation mark over the head of the NPC.

Ark posted Jun 28 '20 at 11:32 pm

When picking pockets you apparently get access to quest items you are really not supposed to. Although i love the idea of allowing for a sneaky rogue who solves delivery quests without killing, i believe that picking a farmers skull without him noticing ( or missing it) is being a bit too good of a rogue. (Hillsbrad, the horde quest where you need to gather several hillsbrad human skulls, was the example i mentioned. My belf rogue picked all the skulls from their pockets ).

recent by Ark  ·  Jun 29 '20 at 8:32 am

[MINOR] When under the touch of zanzil poison, i suffer the -15 to agility but i can enter stealth just fine.

[MAJOR] Doctor Mixilpixil is despawning after the quest is flagged as complete, and i need him in order to deliver so he will give me the antidote. So i still have the poison debuff. Let me just hope he will respawn.

recent by Ark  ·  Jun 29 '20 at 6:05 am
Hide topic messages
Enable infinite scrolling
All posts under this topic will be deleted ?
With selected deselect topics
Pending draft ... Click to resume editing
Discard draft